Home>>Forum>>Support>> New Post
  • Blank page after install
  • 2017-05-19 08:55:18
Hello. I have tried my best to install this for the past few days. I don;t seem to come right. I would appreciate if someone could assist me in getting this right.

Here are my steps:
1. I downloaded the latest file from gitHub. https://github.com/inoerp/inoERP/archive/master.zip
2. unzipped on the server (I use a centos server)
3. I made sure I am using php7
4. I saw 2 folders only: www and inoerp_server
5. I created a subdomain pointing to the www folder
6. I went into inoerp_server/includes/basics/settings/dbsettings.php and set the database details
7. I went to the domain and run install.php (using a browser)
8. It first complained that the htaccess is non-existent and I can (after installing) copy it from www/includes/engine/install/.htaccess and put it in www/.htaccess
9. After I continued, it gave me 100% done and I can now go to the system.
10. I made sure the install.php is not there
11. When I go to the frontpage I see the login buttons on the top side and here is where the trouble starts:
1. If I login with wrong username and password, it tells me it is wrong
2. if I log in with the right username and password, it goes to the following url: app.domain.com/extensions/ino_user/user_login.php and this is where I simply get a blank screen.

I don't know what else to try! I think the .htaccess my be wrong? Here is what I currently have in it:


#Make sure no can access the directories through HTTP
Options -Indexes


#Make index.php as home page
DirectoryIndex index.php

#for conten url alias
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^content/([A-Za-z0-9-]+)/?$ content.php?$1 [NC,L]
# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php70” package as the default “PHP” programming language.

AddType application/x-httpd-ea-php70 .php .php7 .phtml

# php -- END cPanel-generated handler, do not edit
  • blank screen
  • Support    
  • Anonymous
  • 2017-05-19 10:45:15
Aha - so I found the problem: for all of those who get stuck with blank page!
The issue is the file that got downloaded!!!!

You need to download the file from sourceforge - not from github. Or if you do, just check that it doesn't have a www folder because that seems to be the development files.

You need to have one single folder with all the necessary files installed inside it!!!
So just check before you download the wrong one and get stuck for 3 days! ;) Reply
SourceForge contains the released versions, not the latest development version.

So, you should use github. if you want the latest version.
Regarding your issue. Make sure you have the right folder structure
i.e.
-inoerp_server
--assets/vendor
--custom/include
--documents
--extensions
--includes
--locale
--misc
--modules
--tparty
--define_const.inc
--popover_select.php

-www (or http or whatever is your server is pointing to )
--css
--extensions
--files
--includes
--js
--modules
--public
--.....................etc.................Reply
  • Anonymous
  • 2017-05-22 13:16:40
file structure is as mentioned but still brings blank page, kindly elaborate what you mean by2Make sure you have the right folder structureReply
  • Anonymous
  • 2017-05-22 21:32:12
put all the contents of www in your public directory.
inoerp_server should be at the same level as www (or the corresponding folder)Reply
 Per Page
  •   Select File
  • Reply as
  •   Subscribe

All inoERP code is Copyright by the Original Authors as mentioned on COPYRIGHT.txt file.
inoERP is an open Source software; you can redistribute it and/or modify it under the terms of the Mozilla Public License Version 2.0